All tests failing due to wrong Ruby version


#1

Hi there,
we’re having all our tests fail. While looking into it we discovered that the builds are running Ruby 2.3.0 while we’re specifying Ruby 2.3.1 in our .ruby_version file.

Anyone else having problems with this?


#2

If your build is using our 12.04 container, you’ll need to install Ruby 2.3.1 - here’s how to do that: Ruby 2.3.1 on Precise

If you’re using the 14.04 containter, 2.3.1 is preinstalled and should work. Perhaps you could share your circle.yml file if you’re getting issues with 14.04?


#3