Im getting the following failure on circle CI (yarn dependency step) that I am not getting locally:
yarn install v0.21.3 [1/4] Resolving packages... ⠁ success Nothing to install. success Saved lockfile. $ cd client && yarn install yarn install v0.21.3 [1/4] Resolving packages... ⠁ [2/4] Fetching packages... error firstname.lastname@example.org: The engine "node" is incompatible with this module. Expected version ">=4.3.0 <5.0.0 || >=5.10". error Found incompatible module
I followed Circle CI’s guidance on using yarn and have exactly what was prescribed in my circle.yml file. The version of Yarn circle CI is using is 0.21.3, which is from two months ago. I ran this locally on 0.23.2 and 0.22.0 without error. It’s possible this is the cause of the error, but I’m unclear how I can update yarn on circle CI (if that’s even possible).
This issue looks similar to the following issue posted on Yarn’s github. However, Yarn’s maintainers don’t want a bug filed if it’s not about the current version. This is understandable given that I’m not able to replicate this issue locally on the current version of Yarn. This makes me think updating yarn on Circle CI is the only path forward to getting a green build.
Any guidance would be greatly appreciated. Thanks in advance!!