Yarn package error


#1

I’m seeing this error. What’s strange is, I use the same circleci script for another project, using all the same versions in the package.json (the repos backing the projects are configured identically), and it works fine. I’ve tried removing the lines that restore caches, doing the dependencies force thing I found elsewhere, nothing seems to work, the yarn install just dies there.

This is really sort of in my way, I can’t get full pipeline deploy out, I have to do a manual build/sync.

error An unexpected error occurred: “https://registry.yarnpkg.com/event-stream/-/event-stream-3.3.6.tgz: Request failed “404 Not Found””.
info If you think this is a bug, please open a bug report with the information provided in “/home/circleci/project/yarn-error.log”.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
Exited with code 1


#2

It looks like it is requesting information on a specific package. I wonder, maybe 3.3.6 is an unsupported version? If so, is there a yarn update to help it get the latest versions in its remote repo?

Ah, I just did this search and found this report - it says that this version has been unpublished.


#3

Think I fixed it (figures, I’m stuck for a day, post the question, and 15 minutes later figure it out). Posting as it may help somebody else out.

Here’s what I did:

Delete yarn.lock file, push the repo without it. The CI will say couldn’t find the file, continue to run, etc. Problem seemed to go away other than the failure on not finding yarn.lock.

Reinstalled repo with yarn (creates new lock file). Pushed, CI dependency error went away.


#4

Make sure it still passes your tests. A better fix might have been to amend the one library to the first release after the unpublished version, and then update.


closed #5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.