Xcode 11 Beta 6 Released

We have released an Xcode 11 Beta 6 image today. You can select the image by adding the following to a job in config.yml :

macos:
  xcode: 11.0.0

The main change in this image compared to the beta 5 image is the version of Xcode:

  • Xcode is now version 11.0 Beta 6 Version 11M392q
  • Since this is a beta image, we have a reduced set of simulators, all running iOS 13. We will add more simulators to the final image.

Minor changes:

  • NodeJS was upgraded 12.6.0 -> 12.8.1
  • git upgraded from 2.22.0_1 to 2.23.0

The full manifest of the installed software and SDKs is available here.

Known issues

  • There is an issue where a dialog appears for the first 30 seconds after the image boots reporting that the OS did not shut down cleanly on the last boot. This might impact UI tests. We pre-boot VMs so that builds can start as quickly as possible, so in many cases our VMs have been booted more than 30 seconds prior before to build running, which will reduce the rate of occurrence of this bug.

Upcoming deprecations / changes

2 Likes

Is it possible to install xcode11 command line tools?
My project depends on slather https://github.com/SlatherOrg/slather
I am getting an error

Installing nokogiri 1.10.4 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
/Users/distiller/project/vendor/bundle/ruby/2.3.0/gems/nokogiri-1.10.4/ext/nokogiri
/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/bin/ruby -r
./siteconf20190826-765-1hjz5yk.rb extconf.rb
mkmf.rb can't find header files for ruby at
/System/Library/Frameworks/Ruby.framework/Versions/2.3/usr/lib/ruby/include/ruby.h

extconf failed, exit code 1

Gem files will remain installed in
/Users/distiller/project/vendor/bundle/ruby/2.3.0/gems/nokogiri-1.10.4 for
inspection.
Results logged to
/Users/distiller/project/vendor/bundle/ruby/2.3.0/extensions/universal-darwin-18/2.3.0/nokogiri-1.10.4/gem_make.out

An error occurred while installing nokogiri (1.10.4), and Bundler
cannot continue.
Make sure that `gem install nokogiri -v '1.10.4' --source
'https://rubygems.org/'` succeeds before bundling.

In Gemfile:
  slather was resolved to 2.4.7, which depends on
    nokogiri
Exited with code 5