Workflow build without branch name stuck

python
workflow
2.0

#1

Hi there,

We started using workflows in the past week, and overall it works well.
Today, my build ran into a weird state, when merging a pull request on the master branch.

The UI doesn’t show the " / " as usual, just "/ ", and it shows as “Running” as workflow status, but all the steps are in purple state (not running/queued). The build state do not show up in the “build” section and from the workflow, they are not clickable, I cannot open the individual step.

It’s been like this for about 2 hours (our overall build takes ~10 mins normally) and my build queue has been empty the whole time. Is that something you’re aware of?

Thanks


#2

We had a minor incident on our side. We have resolved the issue and deployed the fix. Please let us know if you are still facing issues.


#3

Ok thanks. Right, I see a few builds have gone through, and I just tried a push and it worked.
The build in question is still “running” but it’ll be gone soon.

Thanks for your answer.


#4