Workflow Build not Running After Excluding Branch in Prior Build


#1

I’ve been building my project fine all along, then I updated my config.yml to exclude a few branches. Now I’d like to actually build this new (previously excluded) branch. No matter what I do I cannot force it to build the branch.

The part about “previously excluded” is really just my best guess at why it’s not building. I squandered an hour trying to find out how to trigger a build using the API, but it looks like that endpoint is very limited in what it can do. Workflows are a no-go, as far as I can tell.

Is there some API endpoint that I’m missing? What can I do to get these builds going? I’ve tried the API endpoint https://circleci.com/api/v1.1/project/bitbucket/<org>/<repo>/tree/<branch-name> but no luck. I tried removing webhook from Bitbucket, un-following and re-following as suggested elsewhere. No dice.

Running the config checker says there are no config issues:

➜ circleci config validate
Config file at .circleci/config.yml is valid.

Update: turns out this was due to a malformed branch-filter expression. Was trying to do a regex style rule but wasn’t quite right with the syntax.