Unable to run workflow with context: Could not find context <name>

I have a very simple context setup. It’s called “oss” and is completely default settings-wise. When attempting to run a workflow with a job that uses that context I see the error ‘Could not find context “oss”.’ in the UI.

I have tried different contexts with different names. I have tried waiting and running again over a period of 30 minutes. Am I missing something? The build is on an account that is piggybacking a paid account, and I see the contexts in both orgs interestingly enough.

The graphQL queries to the “graphql-unstable”(heh) endpoint are using the same ownerId/orgId on GET and POST regardless of the org I’m under. Is it possible it’s storing and showing me the contexts for my billing org and the builds in my piggyback account are not able to access them there?


This is a known bug at the moment with piggiebacked orgs and our contexts page. We have a new contexts page coming soon that will resolve it, but I don’t have a timeline at the moment for the release.

You may want to consider using project level environment variables for now if it’s possible. if not, and you really need contexts, we can enable the new contexts UI for your organization. But please submit a support ticket so we can track this request better https://support.circleci.com/hc/en-us/requests/new reference this post in the ticket and someone will be able to assist your further