Unable to Rerun Workflow after opting into third-party orbs

I tried to use a third-party orb, and got a build error:

#!/bin/sh -eo pipefail
# Orb react-native-community/react-native@6.1.0 not loaded. To use this orb, an organization admin must opt-in to using third party orbs in Organization Security settings.
# -------
# Warning: This configuration was auto-generated to show you the message above.
# Don't rerun this job. Rerunning will have no effect.

We then enabled third-party orbs. Despite the warning at the bottom of the message, rerunning the workflow should in fact work now. But rerunning is disabled in the menu:


Am I doing something wrong? What’s the next step supposed to be here?


The error is a bit confusing as you have seen.

When the error Don't rerun this job. Rerunning will have no effect. is shown the front end will not allow you to rerun the job again as it would only cause it to fail once more.

We would recommend pushing a new commit even if it’s just a blank line to your config.yml which should no longer have the same error due to the third-party orb setting being enabled.

Sorry for any confusion caused

Kind Regards
Owen Oliver

But that’s exactly my point: that statement is false. It would pass if I re-ran it, because I’ve changed the project settings.

1 Like


Thank you for following up on this issue, I have gone ahead and raised a feature request for you which is linked below.

Please feel free to add a vote which will allow you to be updated as progress is made on the feature request and if I have missed anything feel free to add a comment.

Kind Regards
Owen Oliver