Rerun workflow does not work

Hi All,

I am unable to use “rerun workflow”. It seems like this is a new button to retry builds (in make case - flaky builds because of Circle CI being quite slow). When I click that the build ends up with “NOT RUN” and warning about Open Pull Request configuration option. Example build: https://circleci.com/gh/improbable-eng/thanos/907 The frustrating part, is that the PR is open, so not sure what’s wrong here (:

The good part of it is that I can “Rerun with SSH” (although I don’t care about SSH session here) just fine and it works.

Do you think you can fix the “Rerun workflow” operation? It seems more sensible when I don’t care about SSH. Also some auto-rerun (with some retry max count) would be nice for those flaky builds (based on error you get from build step?)

Kind Regards,
Bartek

BTW Great job with Circle CI 2.0 - works quite nicely, it is the first broken thing I have seen (maybe except slooow CI from time to time, but I cannot complain when I am on free container for F/OSS projects)

I have filed this as CIRCLE-13446 in our internal systems, but I’m unable to reproduce. I did these steps:

  1. Push a commit on a project with build processing on that has PR-only builds on before PR: Not Run
  2. Make a PR: Build is run and successful
  3. Rerun the build made from the PR: Build is run and successful

I tried both rerun from the jobs page and from the workflows page - both worked as above.

I tried clicking through from the job on the PR check in GH just to be sure - same result as above.

We have been making active fixes to the new build processing pipeline in the last 48 hours, so it’s possible it was fixed since you posted this. Will you please try again, and post back the steps you took if it reproduces?

Keep in mind that you may need to make a fresh build from a new PR rather than rerunning one that was broken before. Depending on the underlying cause, it’s POSSIBLE that rerunning an older build could run into an older problem that is fixed for newer builds because we store the processed configuration and some settings, so if any of that was in a bad state at the time of your old build it’s POSSIBLE you’d see a repeat of the behavior even though it’s now fixed for all subsequent builds.

Thank you for quick response!

For you repro case, can you maybe… between step 2 and 3, approve the PR? (: Maybe that changes something? We can repro rerun problem on some PRs and on some not.

Keep in mind that you may need to make a fresh build from a new PR rather than rerunning one that was broken before.

Cool, will let you know if we will repro this for new PRs!

Kind Regards,
Bartek

This is clearly still broken. https://circleci.com/workflow-run/701143a9-5e6a-435f-99fd-4058576ff9ac

Rerun with SSH works, Rerun workflow is broken.

Hello,

Is there any fix for this issue?
I’m also unable to use “Rerun” button. When a build fails due to an intermittent test and I try to rerun it, build status is set to “not run”. It shows an alert related to “Only build pull requests” option, but the PR is open and PR number is displayed on Job details page.
After some “not run” builds, I had to turn off “Only build pull requests” option to rerun it.

Thanks in advance,

Tatiane