Ubuntu 14.04 Build Image Update 201605-04

build-image

#1

We are shipping a new Ubuntu 14.04 build image. Since the change is very small, we are doing the update without notifications in advance.

Fixing timezone change issue

We had an issue with changing timezone on Ubuntu 14.04 build image. For example, the following circle.yml should change the timezone of the container to America/Los_Angeles but this doesn’t work on the build image.

machine:
  timezone:
    America/Los_Angeles

This issue will be fixed with this update.

All changes

 {
   "summary": {
-    "build-image": "trusty-569-5b00f58",
+    "build-image": "trusty-575-884bd0f",
     "google-chrome": "50.0.2661.102",
     "chromedriver": "2.21.371461",
     "firefox": "46.0.1",
@@ -85,7 +85,7 @@
     },
     "redis": "2.8.4",
     "memcached": "1.4.14",
-    "git": "2.8.2",
+    "git": "2.8.3",
     "gcc": "4.8.4",
     "g++": "4.8.4",
     "cc": "4.8.4",
@@ -108,7 +108,7 @@
     "docker-compose": "1.5.2",
     "heroku-toolbelt": "3.43.2",
     "gcloud": "110.0.0",
-    "aws-cli": "1.10.31",
+    "aws-cli": "1.10.32",
     "android": {
       "build-tool": "24.4.1",
       "build-tools": [
@@ -173,11 +173,11 @@
     "beanstalkd": "1.9-2ubuntu1",
     "bind9-host": "1:9.9.5.dfsg-3ubuntu0.7",
     "binfmt-support": "2.1.4-1",
-    "binutils": "2.24-5ubuntu14",
+    "binutils": "2.24-5ubuntu14.1",
     "bison": "2:2.7.1.dfsg-1",
     "bridge-utils": "1.5-6ubuntu2",
     "bsdmainutils": "9.0.5ubuntu1",
-    "bsdtar": "3.1.2-7ubuntu2.1",
+    "bsdtar": "3.1.2-7ubuntu2.2",
     "bsdutils": "1:2.20.1-5.1ubuntu20.7",
     "btrfs-tools": "3.12-1ubuntu0.1",
     "build-essential": "11.6ubuntu6",
@@ -354,8 +354,8 @@
     "gir1.2-gst-plugins-base-1.0": "1.2.4-1~ubuntu2",
     "gir1.2-gstreamer-1.0": "1.2.4-0ubuntu1",
     "gir1.2-rsvg-2.0": "2.40.2-1",
-    "git": "1:2.8.2-0ppa1~ubuntu14.04.1",
-    "git-man": "1:2.8.2-0ppa1~ubuntu14.04.1",
+    "git": "1:2.8.3-0ppa1~ubuntu14.04.1",
+    "git-man": "1:2.8.3-0ppa1~ubuntu14.04.1",
     "gnupg": "1.4.16-1ubuntu2.3",
     "google-chrome-stable": "50.0.2661.102-1",
     "gpgv": "1.4.16-1ubuntu2.3",
@@ -429,7 +429,7 @@
     "libapt-inst1.5:amd64": "1.0.1ubuntu2.11",
     "libapt-pkg4.12:amd64": "1.0.1ubuntu2.11",
     "libarchive-extract-perl": "0.70-1",
-    "libarchive13:amd64": "3.1.2-7ubuntu2.1",
+    "libarchive13:amd64": "3.1.2-7ubuntu2.2",
     "libarmadillo4": "1:4.200.0+dfsg-1",
     "libarpack2": "3.1.5-2",
     "libasan0:amd64": "4.8.4-2ubuntu1~14.04.3",
@@ -1070,7 +1070,7 @@
     "libxxf86vm1:amd64": "1:1.1.3-1",
     "libyaml-0-2:amd64": "0.1.4-3ubuntu3.1",
     "libyaml-dev:amd64": "0.1.4-3ubuntu3.1",
-    "linux-libc-dev:amd64": "3.13.0-86.130",
+    "linux-libc-dev:amd64": "3.13.0-86.131",
     "lksctp-tools": "1.0.15+dfsg-1",
     "llvm": "1:3.4-0ubuntu1",
     "llvm-3.4": "1:3.4-1ubuntu3",

#2