Ubuntu 12.04 Container Image Update 201604

build-image

#1

We will update our Ubuntu 12.04 build container image between 28th and 29th Apr.

Here are major fixes/changes included in the update:

Apache PHP module support for PHP 7.0.4

The PHP module libphp7.so has not been installed in the build image. In this update, we will install the module under ~/.phpenv/versions/7.0.4/libexec/apache2/libphp7.so.

Updating Android SDK tool to r24.4.1

We will update Android SDK tool to r24.4.1.

Installing Android SDK build tool 23.0.2

We’ve incorrectly documented that Android SDK build-tool 23.0.2 is pre installed. In this update, we will make sure the version is pre-installed.

Updating Ruby gem to 2.6.3

Some of our customers had an issue that manually updating to newer version of bundler doesn’t work and old version gets always used. This is due to a bug in Ruby gem which has been fixed in 2.6.3.

Installing newer SBT

SBT 0.13.10 and 0.13.11 are now pre-installed

Other changes

The below are the list of all changes.

package old-version new-version
apt-transport-https 1.0.1ubuntu2.11 1.0.1ubuntu2.13
chef 12.8.1-1 12.9.38-1
ffmpeg 4:0.8.17-0ubuntu0.12.04.1 4:0.8.17-0ubuntu0.12.04.2
firefox-locale-de 45.0+build2-0ubuntu0.12.04.1 45.0.2+build1-0ubuntu0.12.04.1
firefox-locale-ja 45.0+build2-0ubuntu0.12.04.1 45.0.2+build1-0ubuntu0.12.04.1
gem 2.6.3
git-man 2:2.7.2-1avh1~precise1 2:2.8.1-1avh2~precise1
heroku 3.42.44 3.43.0
heroku-toolbelt 3.42.44 3.43.0
libapache2-mod-php5 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
libav-tools 4:0.8.17-0ubuntu0.12.04.1 4:0.8.17-0ubuntu0.12.04.2
libavcodec-dev 4:0.8.17-0ubuntu0.12.04.1 4:0.8.17-0ubuntu0.12.04.2
libavdevice53 4:0.8.17-0ubuntu0.12.04.1 4:0.8.17-0ubuntu0.12.04.2
libavfilter2 4:0.8.17-0ubuntu0.12.04.1 4:0.8.17-0ubuntu0.12.04.2
libavformat-dev 4:0.8.17-0ubuntu0.12.04.1 4:0.8.17-0ubuntu0.12.04.2
libavformat53 4:0.8.17-0ubuntu0.12.04.1 4:0.8.17-0ubuntu0.12.04.2
libavutil-dev 4:0.8.17-0ubuntu0.12.04.1 4:0.8.17-0ubuntu0.12.04.2
libmysqlclient-dev 5.5.47-0ubuntu0.12.04.1 5.5.49-0ubuntu0.12.04.1
libmysqlclient18 5.5.47-0ubuntu0.12.04.1 5.5.49-0ubuntu0.12.04.1
libmysqlclient18:i386 5.5.47-0ubuntu0.12.04.1 5.5.49-0ubuntu0.12.04.1
libpcre3 1:8.31-2ubuntu2.1 1:8.31-2ubuntu2.3
libpcre3-dev 1:8.31-2ubuntu2.1 1:8.31-2ubuntu2.3
libpcre3:i386 1:8.31-2ubuntu2.1 1:8.31-2ubuntu2.3
libpcrecpp0 1:8.31-2ubuntu2.1 1:8.31-2ubuntu2.3
libpostproc52 4:0.8.17-0ubuntu0.12.04.1 4:0.8.17-0ubuntu0.12.04.2
libpq-dev 9.5.1-1.pgdg12.4+1 9.5.2-1.pgdg12.4+1
libpq5 9.5.1-1.pgdg12.4+1 9.5.2-1.pgdg12.4+1
libsmbclient 2:3.6.3-2ubuntu2.17 2:3.6.25-0ubuntu0.12.04.2
libsnmp-base 5.7.2~dfsg-8.1ubuntu3.1 5.7.2~dfsg-8.1ubuntu3.2
libsnmp-dev 5.7.2~dfsg-8.1ubuntu3.1 5.7.2~dfsg-8.1ubuntu3.2
libsnmp30 5.7.2~dfsg-8.1ubuntu3.1 5.7.2~dfsg-8.1ubuntu3.2
libswscale-dev 4:0.8.17-0ubuntu0.12.04.1 4:0.8.17-0ubuntu0.12.04.2
libswscale2 4:0.8.17-0ubuntu0.12.04.1 4:0.8.17-0ubuntu0.12.04.2
libtiff-tools 3.9.5-2ubuntu1.8 3.9.5-2ubuntu1.9
libtiff4 3.9.5-2ubuntu1.8 3.9.5-2ubuntu1.9
libtiff4-dev 3.9.5-2ubuntu1.8 3.9.5-2ubuntu1.9
libtiff4:i386 3.9.5-2ubuntu1.8 3.9.5-2ubuntu1.9
libtiff5 4.0.3-7ubuntu0.3 4.0.3-7ubuntu0.4
libtiffxx0c2 3.9.5-2ubuntu1.8 3.9.5-2ubuntu1.9
libudev1 204-5ubuntu20.18 204-5ubuntu20.19
libwbclient0 2:3.6.3-2ubuntu2.17 2:3.6.25-0ubuntu0.12.04.2
mysql-client-5.5 5.5.47-0ubuntu0.12.04.1 5.5.49-0ubuntu0.12.04.1
mysql-client-core-5.5 5.5.47-0ubuntu0.12.04.1 5.5.49-0ubuntu0.12.04.1
mysql-common 5.5.47-0ubuntu0.12.04.1 5.5.49-0ubuntu0.12.04.1
mysql-server 5.5.47-0ubuntu0.12.04.1 5.5.49-0ubuntu0.12.04.1
mysql-server-5.5 5.5.47-0ubuntu0.12.04.1 5.5.49-0ubuntu0.12.04.1
mysql-server-core-5.5 5.5.47-0ubuntu0.12.04.1 5.5.49-0ubuntu0.12.04.1
mysqld 5.5.47-0ubuntu0.12.04.1 5.5.49-0ubuntu0.12.04.1
neo4j 2.3.2 2.3.3
openjdk-7-jdk 7u95-2.6.4-0ubuntu0.12.04.1 7u95-2.6.4-0ubuntu0.12.04.2
openjdk-7-jre 7u95-2.6.4-0ubuntu0.12.04.1 7u95-2.6.4-0ubuntu0.12.04.2
openjdk-7-jre-headless 7u95-2.6.4-0ubuntu0.12.04.1 7u95-2.6.4-0ubuntu0.12.04.2
openjdk-8-jdk 8u72-b15-1~precise1 8u91-b14-0ubuntu4~12.04
openjdk-8-jdk-headless 8u91-b14-0ubuntu4~12.04
openjdk-8-jre 8u72-b15-1~precise1 8u91-b14-0ubuntu4~12.04
openjdk-8-jre-headless 8u72-b15-1~precise1 8u91-b14-0ubuntu4~12.04
optipng 0.6.4-1 0.6.4-1ubuntu0.12.04.1
php 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
php-pear 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
php5-cli 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
php5-common 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
php5-curl 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
php5-dev 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
php5-gd 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
php5-intl 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
php5-ldap 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
php5-mysql 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
php5-sqlite 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
php5-xsl 5.3.10-1ubuntu3.21 5.3.10-1ubuntu3.22
postgresql-9.4 9.4.6-1.pgdg12.4+1 9.4.7-1.pgdg12.4+1
postgresql-client-9.4 9.4.6-1.pgdg12.4+1 9.4.7-1.pgdg12.4+1
postgresql-client-common 172.pgdg12.4+1 173.pgdg12.4+1
postgresql-common 172.pgdg12.4+1 173.pgdg12.4+1
postgresql-contrib-9.4 9.4.6-1.pgdg12.4+1 9.4.7-1.pgdg12.4+1
postgresql-plpython-9.4 9.4.6-1.pgdg12.4+1 9.4.7-1.pgdg12.4+1
postgresql-server-dev-9.1 9.1.20-1.pgdg12.4+1 9.1.21-1.pgdg12.4+1
postgresql-server-dev-9.4 9.4.6-1.pgdg12.4+1 9.4.7-1.pgdg12.4+1
psql 9.4.6 9.4.7
ruby 1.9.3p448
tzdata 2016b-0ubuntu0.12.04 2016c-0ubuntu0.12.04
tzdata-java 2016b-0ubuntu0.12.04 2016c-0ubuntu0.12.04

#2

I can confirm my Android project building and my tests running smoothly after this change has been applied. Thanks a lot!


#3

#4