Switched our template over to 2.0 and getting git error trying to pull remote ref


#1

fatal: Couldn’t find remote ref ? Any ideas on what might be going on, had no issues on our 1.0 template.


Could Not Find Commit
#2

In general, when seeking help, please supply all the information necessary to help you in your question, rather than waiting to be asked. We’d probably need to see your config.yml file at least (this can be supplied in a formatted block).

The error sounds like a branch problem, so readers may need information about what branch you’re expecting - does it have a master?


#3

Template is pretty straightforward, build was initiated from a pull request branch.

version: 2
jobs:
  build:
    docker:
      - image: circleci/java:8
        environment:
          - PG_HOST=localhost
          - PG_USER=ubuntu
      - image: postgres:9.6
        environment:
          - POSTGRES_USER=ubuntu
          - POSTGRES_DB=portal
    steps:
      - checkout

Full error:

Cloning into '.'...
Warning: Permanently added the RSA host key for IP address '192.30.253.112' to the list of known hosts.

remote: Counting objects: 215384, done.        
remote: Compressing objects: 100% (73/73), done.        
remote: Total 215384 (delta 62), reused 33 (delta 33), pack-reused 215278        
Receiving objects: 100% (215384/215384), 102.16 MiB | 21.23 MiB/s, done.
Resolving deltas: 100% (169341/169341), done.
Checking connectivity... done.
Warning: Permanently added the RSA host key for IP address '192.30.253.113' to the list of known hosts.

fatal: Couldn't find remote ref pull/6229/head
Exited with code 128

#4

I wonder if it’s getting confused because the developer named their branch with a slash in it ‘pull/6229’


#5

That looks like a Git repository problem to me. I don’t think the slash is a problem - they are often used in feature-branch names.

Have you tried cloning the repo locally? Are you using a Git hosting provider (BitBucket, GitHub, etc) or are you self-hosting? I wonder if a git fsck is in order on the remote repo (do git help fsck and back up your master repo first).

Also, various solutions here. Not a CI issue, in my opinion.


#6

We’re using GitHub BTW. Going to do some digging on this locally and see if I can replicate it


#7

Gotcha. Someone else is having trouble with GitHub/Circle - see the related link under your OP. Maybe I will have to eat my hat, and it is a Circle issue! :smirk_cat:


#9

Sooo wierd… So branches created with pull/ in them fail, while branches with whatever/ are ok. I’m sure this is something with the github repo, trying to figure out what. Wierd thing is jenkins builds the same repo same branch just fine

For the pull/ branches circle bash script does (note head appended to end in pull/)

git fetch --force origin “pull/5234_widget/head:remotes/origin/pull/5234_widget”

and for the others:

git fetch --force origin “jason/did_something:remotes/origin/jason/did_something”


#10

I ran into a similar issue. Weird thing is, branch names with a single slash work fine, but not multiple slashes!


#11

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.