SSH Permission key not injected in build container anymore

This worked fine up until last night, but now we experience the problem that the ‘SSH Permission’ key we’ve added, is not injected anymore.

defaults: &defaults
      - image:
          username: xx
          password: xx
# also tried '2.0', '2'
version: 2.1
    <<: *defaults
      - add_ssh_keys:
            - "xx:...:xx"
      - checkout
      - run:
          name: deploy
          command: |
            ssh -T

Goes without saying; the fingerprint is the same value as the fingerprint displayed in SSH Permission.

It used to work fine, even without the ‘add_ssh_keys’ (version: 2). If we take and old project and click rebuild, we still get the behaviour from before: The ssh -T command shows the full list of what we have access to through that fingerprint key. If we remove it, and rebuild, we see that the access drops.

However, if we do the same for a new project this doesn’t work anymore (maybe since last night, definitely since this morning). It only wants to use the ‘CircleCI Deploy Key’ that is added
automatically and is registered in the (bitbucket) repo.

Is anyone experiencing something similar since the last day or so ?

Any thoughts on what we can try ? We’ve already tried with multiple repo’s, copying the files and config.yaml script that worked for the ‘old’ rebuild triggers to newly created repo’s, …
Nothing seems to work anymore.

Any help is much appreciated.

Hi Carlo. This is strange. A question:

  • Does this work on old projects, with new commits?

I’ve made 2 types of changes, in both cases it worked:

  1. Normal change to actual content of the repo
  2. Change to the config.yaml file (version: 2 -> version: 2.1)

screenshot of the message (the fail is afterwards, as it’s an old test repo):

I’m slightly confused here. Does this mean it’s working again?

it works for an old repo. When I copy the exact same script to a new repo, and configure it the same, it doesn’t work.

Gotcha. I’m not sure what is happening here, can I ask you to create a ticket so we can dig in?

Done. Thanks for your quick replies.

1 Like