Add_ssh_keys is not working

I followed the instructions for adding a Github Deploy Key at:

This worked fine on 2 private repos that I own. However, when I tried the same steps on a private repo owned by an organization, no SSH key is added when CircleCI runs the add_ssh_keys command. All I get is the message:

There are no configured ssh keys to install

I’ve tried removing and re-adding the key, creating a new key, and double checking that the steps are the same by going through it on my private repos again. I don’t understand why this is not working on the org owned private repo.

I’ve also SSHed into the running job on both environments and was able to confirm that in my private repos, I see the id_rsa_fingerprint file, but do not see that same file on the org owned private repo. While ssh’ed into the container, I also manually created the file along with the corresponding entry in ~/.ssh/config and was then able to clone down the other private repo. So the deploy key was definitely setup correctly on the Github side.

Is there a step that I’m missing?

Edit: I want to use a deploy key in this build job because I need to get the code for a git submodule.