Ruby-version version detection with a gemset is broken on trusty

ruby
trusty

#1

Looks like using a .ruby-version that specifies a gemset is broken on the 14.04 build environment.

Example broken: https://circleci.com/gh/usmu/usmu-github-pages/14

Rebuild on 12.04: https://circleci.com/gh/usmu/usmu-github-pages/15


#2