[resolved] Meteor/Spacejam suddenly failing with mysterious exit code


#1

Hi there,

Since today, I am getting the following error. To verify that it’s not “me”, I even re-ran a previously successful run, and it failed with the exact same error. Finally, I ran the exact same command on my computer and it passes successfully.

Was there a recent change that could have affected PhantomJS?

Thank you

=> Started your app.

=> App running at: http://localhost:4096/
spacejam: meteor is ready
spacejam: spawning phantomjs
: No such file or directory
spacejam: phantomjs exited with code: 127
spacejam: killing meteor
I20160227-08:03:45.326(0)? test-in-console listening
spacejam: meteor killed with signal: SIGTERM

spacejam: Unknown error with exit code '127'. Exiting. spacejam test-packages --use-system-phantomjs returned exit code 127

#2

Oooh. I just noticed the “No such file or dir” part.

It seems like there is a new version of phantomjs2 since yesterday, so this bug probably belongs there :slightly_smiling:

Please ignore.


#3