Pushing branch to origin master doesn't trigger CI build


#1

Just curious if I’m missing a setting. Pushing a branch to origin master doesn’t seem to trigger a build…


#2

Is this a public project? If so, can you paste the build URL?


#3

If this is the first time building a new project on CircleCi you’ll need to go to add project in circle and tell it to build. Circle won’t sniff out the project automatically until you tell it to watch it.


#4

It is not a public project, but it has been added to my watch list. It shows that I’m following it in Project Settings>Overview. Pushing my branch or submitting a PR doesn’t seem to trigger anything.


Branches not building
#5

I should clarify, it did for a second, when I submitted the first PR, it started the build automatically. But now nothing happens.


#6

Replied below.


#7

Can you check the hooks in GitHub to see if one came through?

The location in GitHub is: https://github.com/$ORG/$REPO/settings/hooks


#8

It doesn’t look like it.


#9

Could you please unfollow and then re-follow the project on CircleCI? This should re-add the webhook to GitHub in case it got deleted for some reason.


#10

I’ve tried that a few times. It seems to work for a minute and then stops…


#11

Is the CircleCI webhook still present at https://github.com/<username>/<project-name>/settings/hooks?


#12

Yes, it is.


#13

This is very strange. Does your org have third-party restrictions enabled on GitHub? I don’t think it could work even for the first few times, but still worth checking. Thanks.


#14

No restrictions, although it seems to be sticking. Unfollowing/following seemed to work this time :slight_smile:


#15

I actually want to echo that I am currently having issues with this as well. I tried following and unfollowing with no luck. Building on push worked for like several months, and then just stopped working recently.


#16

I also tried with unfollow and then follow but nothing seems to work. Earlier I was able to build on push but recently it stopped working.


#17

me too! Hahaaa

เกมส์ไฮโล


#18