Pull requests not tested anymore?

workflow

#1

SInce switching to the workflow scheme, pull requests don’t seem to be tested anymore; see [1, 2]. Is there anything I can do here?

[1] https://github.com/nschloe/meshio/pull/101
[2] https://circleci.com/gh/nschloe/workflows/meshio


#2

Do you have ‘build forked pull requests’ enabled? It’s disabled by default. If you have it checked this is definitely a bug though.


#3

Thanks, this fixes the issue. (Never knew that forks don’t build by default; I’m still used to it being otherwise from using travis.)


#4

Yup, totally agree with you that that should be the default (at least with secrets not exposed). Maybe it’s a minor security risk for devs who don’t acknowlege it? Either way, I turn that setting on for everything that I run.


#5

Me again. As of recently, forked PRs do not build; see, e.g., here.

Is there another lever I have to pull?


#6

Unfortunately, CircleCi workflows don’t support forked pull requests (I really hope they add it soon)

https://circleci.com/docs/2.0/faq/#can-i-build-fork-prs-using-workflows

I contacted them earlier about this and they said they’re working on it.

For now, I would suggest just making two linear build steps without workflows, or using the old method of multiple tasks in circleci2.0 (using the api).


#7