Permission denied when running circleci job

tried circleci commands related to config file, all result in
“Error: Could not load config file at .circleci/config.yml: open .circleci/config.yml: permission denied”
I even tried inserting sudo and also giving all permissions (777) to the config.yml and .circleci directory.
Can someone help me here,

What do you get with ls -l .circleci/? I wonder who has user and group ownership of the file, and what user you normally run as.

i got pissed off and gave permissions to everyone, so its rwxrwxrwx for both the directory and file.Also it shows i am the user and my pc is group.

Running on Fedora/Centos/RHEL? This may help you: CircleCI CLI on Linux system issues

If you’re running Fedora/RH use ‘sealert’ command/application and follow the advices given on the details view of the access violation issue. (Should occure twice for circleci CLI: first for “read” access to config.yml, then on “open” access)

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.