Node Version Failure on CircleCI 1.0

nodejs

#1

As of April 26, all of our builds are failing when we hit our pre-testing step yarn global add knex due to You are using Node "4.2.6" which is not supported and may encounter bugs or unexpected behavior.. Node 4.2.6 is the default CircleCI node version and not the version that we are specifying in our circle.yml file. Up to 4/26, we had the following in our circle.yml and everything worked:

node:
version: 8.3.0

After hitting this error, we’ve tried switching to all of the following (since they’re listed as pre-installed node versions) and none work:

node:
version: v8.1.4

node:
version: 8.1.4

node:
version: v8.2.0

node:
version: 8.2.0

Is there something wrong with our circle.yml file and a reason it suddenly stopped working a few days ago?


#2

I’m not 100% sure what this actually does, but it sounds to me like this is a great time to move to 2.0. In this model you have full control over the node version (as there is only a single one installed).


#3

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.