Machine - node - version broken

nodejs
circle.yml

#1

When using the following configuration on Ubuntu 14.04 in circle.yml file :

machine:
node:
version: 5.7

The following guild error is returned during Machine build phase:

Version ‘5.7’ not found - try nvm ls-remote to browse available versions.
nvm install 5.7 && nvm alias default 5.7 returned exit code 3
Action failed: set node.js version to 5.7

SSH’ing into the build machine and running nvm ls-remote results in N/A output which is not expected.
Instead complete output of all available NVM NodeJS versions should be presented, similar to this one:
nvm ls-remote v0.1.14 v0.1.15 v0.1.16 v0.1.17 v0.1.18 v0.1.19 v0.1.20 v0.1.21 v0.1.22 v0.1.23 v0.1.24 v0.1.25 v0.1.26 v0.1.27 v0.1.28 v0.1.29 v0.1.30 ....

Please note that up until yesterday this configuration and builds worked fine.


#2

Is there any update on this issue? We used this workaround which worked for us for the past 2 weeks, but it is not working anymore:
dependencies:
— override:
---- - nvm use 5.7
What happens is that CircleCI is still using nodejs v4.2.6.

Unfortunately we cannot build any jobs any longer which use node v5.7.


#3