Local builds don’t respect –skip-checkout


#1

For some time, using --skip-checkout meant that the circleci CLI for locally running builds just mounted the current directory. However, now it does a mkdir -p /src && cp -r /tmp/_circleci_local_build_repo/. /src , which can be extremely expensive and time consuming (e.g. when other build artifacts are in the local directory). Can you please make add a flag indicating that it shouldn’t copy over and use the local directory as is? This also makes it easier to inspect build results since they’re not thrown away after the build.


#2

Have you switched over to the new CLI yet? If you have, and this is still an issue, you’ll want to open an Issue here: https://github.com/CircleCI-Public/circleci-cli/issues


#3

Was there any resolution to this? I too am looking for information on how to control how “local” builds perform the “checkout” step.