Jobs that used to run perfectly stopped working suddenly

I’m running Node v14.10 atm, and all my jobs stopped working because it could not find any installed dependencies.

e.g.

yarn run v1.22.5
$ run-p 'setup:*'
/bin/sh: 1: run-p: not found
***** Command failed with exit code 127.

I run yarn before my other projects, save and retrieve it from the cache. It used to work fine, but it stopped working and I have no idea why.

No cache is found for key: v1-dependencies-MMmSVRwYe8Ppuun91YcBlOQQI73wWLgKXJiXQmvV5ak=-m7w12EbAeGgVghEp3ZIRCZCN+4A5qUPJW2+czwv04wo=
Found a cache from build 776 at v1-dependencies
Size: 162 MiB
Cached paths:
  * /home/circleci/project/node_modules
  * /home/circleci/project/packages/@foodbudget/backend/api/node_modules
  * /home/circleci/project/packages/@foodbudget/backend/email/node_modules
  * /home/circleci/project/packages/@foodbudget/backend/jobs/node_modules
  * /home/circleci/project/packages/@foodbudget/frontend/node_modules

Downloading cache archive...
Validating cache...

Unarchiving cache...

And the dependency is there on my package.json.

"npm-run-all": "^4.1.5",

When I run CircleCI locally on my machine it’s fine. (It skipped the cache process, but if I add a new run command called yarn then it works fine).

Here is the link to one of my failed job:

I don’t know if any CircleCI employees are able to look at it, please? Thanks a lot! I’m stuck for multiple days now and it is very frustrating.

EDIT: My project is a monorepo. It looks like yarn does not install any dependencies at the root level, even though it works fine locally…

1 Like

Oh my god… I set NODE_ENV to production on CircleCI, this prevents devDependencies from being installed…

1 Like

Happens to the best of us! I’m glad it’s fixed :smiley: