iTunesConnect distribution (shenzen) error: ipa not found

osx
known-issue

#1

I have been building and distributing to iTunes connect successfully on my project for over a month now, and just today I started seeing the following error during the distribution step of our project (I’ve x’d out our AppleID):

ipa distribute:itunesconnect -i xxxxxxxxxx --upload --verbose
bash: line 1: ipa: command not found

ipa distribute:itunesconnect -i xxxxxxxxxx --upload --verbose returned exit code 127

Action failed: ipa distribute:itunesconnect -i xxxxxxxxxx --upload --verbose

This is a strange one, because I haven’t changed our configuration or had this problem in the past (and we’ve successfully distributed many times). Here’s the deployment configuration found in my circle.yml file:

deployment:
  staging:
    branch: master
    commands:
      - gym
      - ipa distribute:itunesconnect -i xxxxxxxxxx --upload --verbose

Is anyone else experiencing this problem recently, and if so- what solution do you recommend? I’ve tried rebuilding several times but that’s about it.

Thanks!


#2

Thanks for bringing this to our attention. We just released a new macOS image and it looks like there are a couple issues.

We are looking into this right now and will provide an update here.


#3

Thank you very much!! I also SSH’d into my build and verified ipa doesn’t exist (as expected).


#4

Thanks for your patience! The solution is that we need to re-install shenzhen against the newer version of Ruby. We will need to do this in a future image update.

The work around for now is to manually install shenzhen. The easiest way to do this is to add the following to your circle.yml

dependencies:
  pre:
    - gem install shenzhen

This will allow you to use the ipa command. I will update this thread when the workaround is no longer necessary. Thanks again!


#5

I added the dependencies and it worked as expected. I’ll remove the dependencies once I see the issue has been resolved.

Thank you for the quick responses, Lev!


#6

My pleasure! Thank you for confirming that the workaround works.


#7

Thanks for the bug report and effective workaround. Is there an quick mac image rev planned anytime soon, or is this something I need to plan to live with for a while? Over a third of my build time is spent on the gem installation.


#8