After CircleCI went down yesterday, bundle install is now broken on iOS and Android

Hi all,

We’ve been submitting builds to TestFlight and Google Play just fine up until the scheduled maintenance yesterday. When CircleCI came back online, I tried to push a new build and both iOS & Android are failing at the Build IPA or APK part.

Android fail error:
bundler: command not found: fastlane
Install missing gem executables with bundle install

iOS fail error:
Could not find rake-12.3.3 in any of the sources
Run bundle install to install missing gems.

I tried running bundle install on my branch and it installed a bunch of gems but when I went to push up a commit, there was no changes to push.

I think read I needed to change my path in my config from ‘vendor/bundle’ to ‘vendor/cache’. I did this but upon further reading I am hesitant to merge this because now I’d assume i’d have to change the path in my config.yml file. Im hesitant to do this because up until Circle went offline everything was working perfect.

Any thoughts on what I should be doing?

I’m curious, are you able to re-run an older pipeline (from before yesterday) and see if that runs successfully?