Issue with Node env version --> Expected version “>=10.14”. Got “10.13.0”

Hello :),

i need to update the cross-env dependency to 7.0.2 and i get the error : The engine “node” is incompatible with this module. Expected version “>=10.14”. Got “10.13.0”.

i tried to update the node here:
node_defaults: &node_defaults
working_directory: ~/repo
- image: zenika/alpine-node:icu

  • tried to set it to zenika/alpine-node:latest but i get an error with during my cypress run job: error Your lockfile needs to be updated, but yarn was run with --frozen-lockfile.

  • tried to set it to circleci/node:12.16.1 but i get an error at installing dependencies: Unarchiving cache…Failed to unarchive cache (probably cause till now i use - image: zenika/alpine-node:icu)

Any ideas how can i update my node env so i can install the dependency?

thanks in advance

You can try forcing a cache up by adding a version key to your cache key, if it doesn’t have one. example: -v2-node-cache-{{ checksum package-lock.json }} and then try the circleci/node:12.16.1 image again. You can do that on any caches in your job to see if fresh caches on the new image work.

Hi, it did not work…still the same error Unarchiving cache…Failed to unarchive cache

Can you send me the job link in a DM?

i am sorry i am new how can i send a direct message?

Click on my picture, or username, and click the blue “Message” button. You can send me a private message from there.

…strange i dont see any blue button. maybe because i am a new member? Could u be able to send me a DM? thanks i appreciate ur help

maybe because you’re new. I probably have to message first. one sec!

The solution here was to select an executor from the cypress orb that had a more recent version of node and use the executor parameter of the cypress/run job to enable it

i changed nothing in the orbs: cypress

the only thing i did is adding the executor at the workflow at the job of cypress/run

It worked… is that what u would do? did i miss sth?

this executor key is the only thing i added in the config file

yes that’s correct. happy it works!