Issue specifying docker version in orb

Due to issue building a container since the update of our applications to nodejs 14.15 (latest LTS).
I found this CircleCI article indicating that the docker version should be specified.
The build of our container is defined in our dedicated orb so I tried to specify the version in it but my build are failing due to the following error :

Allocating a remote Docker Engine
Requesting version: default

Got error while creating host: failed to create host: rpc error: code = Unknown desc = An internal error occurred when provisioning resources for this job. Provisioning Service returned status code: 403
We had an unexpected error preparing a VM for this build, potentially due to our infrastructure or cloud provider. Please retry the build in a few minutes

It seems like I have 2 issues:

  • the first one is the 403
  • the second one is the fact that it still try to use the default docker engine version instead of the specified version (19.03.13).

Do you have an idea on how to solve the issue?

Problem solved, the issue seems to be due to the naming I used for my orb version. I should not have use - in it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.