GitHub Repo Refused to build complains about expired Orb

Looks like I broke CircleCI. I can’t seem to get a Build that was fine working again. It just show an error about an expired dev Orb, which I’ve published again today, but I still get this error:

Any one know what I should try in order to fix it?

Hi @b01,

Sorry to hear you are running into this issue.

Could I have you first try to manually publish a new dev version of the orb?

For example:

# Pack the orb source
circleci orb pack ./src > orb.yml

# Validate the compiled orb
circleci orb validate orb.yml

# Push the orb dev version
circleci orb publish orb.yml kohirens/version-release@dev:alpha

Following that, please try and run a pipeline in the project from your screenshot.

Yes. I just published again.

Once an orb is created it cannot be deleted. Orbs are semver compliant, and each published version is immutable. Publicly released orbs are potential dependencies for other projects.
Therefore, allowing orb deletion would make users susceptible to unexpected loss of functionality.
Orb `kohirens/version-release@dev:alpha` was published.
Note that your dev label `dev:alpha` can be overwritten by anyone in your organization.
Your dev orb will expire in 90 days unless a new version is published on the label `dev:alpha`.
Please note that this is an open orb and is world-readable.

Same result as above though.

I noticed yesterday that the branches listed in Circle CI are very old, these branches (besides main) have been deleted:

What is on GitHub:

I have tried deleting the existing Deploy key and having CircleCI make a new one, but that does not seem to help.

I also tried to hitting the “stop building” button and start following to see if it would register changes to no avail.

OK. Its running again. Though I’m not sure what fixed it. I’m thinking it could have been due to rotating the GitHub personal access token!?