Error when creating new orb for Orbtoberfest

Hi, I’m trying to create an orb, to participate in Challenge 2. But I keep getting the below error when running circleci orb init yaml-validator-orb

Error: rename /tmp/orb-project-template/CircleCI-Public-Orb-Project-Template-fda640c yaml-validator-orb: invalid cross-device link

Someone else has already faced the same error and created an issue as well. As the challenge is to create an orb using the Orb Development Kit, I did not try the manual orb authoring process. Is there a way to work around this error?

1 Like

@devatherock thanks for the issue report… We’ll review and see what’s going on.

I asked about this in the Github thread, but I’m going to ask here as well.

Do you happen to have any of your directories /home, /tmp mounted to different filesystems or devices? I think a rename is failing that throwing that error

I made a comment in that Github issue about setting the TMPDIR before the init command. Can you try that as well?

I tried init after setting the TMPDIR, still got the same error. Also my /home and /tmp are in the same device, but I noticed something else. My PC runs Ubuntu 20.04 LTS and I installed the circleci CLI using snap install. And it seems every app installed using snap has it own mount point and circleci CLI is mounted on something like /snap/circleci/200. Maybe that’s why the rename is not working?

I was able to recreate this using the snap version of circleci as well.

Yeah, I got around it now by not using the snap version and installing using curl -fLSs https://raw.githubusercontent.com/CircleCI-Public/circleci-cli/master/install.sh | sudo bash. I was able to initialize the orb!

If anyone comes by and wants to try building their own snap version, there is a pull request with a potential fix waiting for review. It is not obvious on how to build the snap version locally, but if anyone is interested, let me know and I can give a short tl;dr for building and installing a new snap locally to test.

Otherwise, you can also wait for this to be merged and deployed.

This affected me too today when I was following the “Orb Authoring Process” docs page. I was using the snap install on Ubuntu 19.10.

Switching to the install method using the script curl’d and piped into bash worked.

1 Like