Error running tests - NameError: uninitialized constant

ruby

#1

We’re getting the following error attempting to run tests in Circle CI 2.0

An error occurred while loading ./spec/views/v1/devices/settings.json.rabl_spec.rb.
Failure/Error: require File.expand_path("../../config/environment", __FILE__)

NameError:
  uninitialized constant RablRails
# ./config/initializers/rabl_config.rb:1:in `<top (required)>'

The error is now repeatable in 2 different branches that were worked by separate people, so we’re pretty sure it’s not a change in one branch that has led to this.

The tests were running prior to this weekend, and run successfully locally as well.

I’ve also tried to require 'rabl-rails' at the top of initializers/rabl_config.rb, which did not resolve the issue.

I’m now out of ideas on how to resolve this. Is there anyone who might have seen something similar who might be able to help?


#2

It looks like this issue is related to the version of bundler on the ruby image. Following the steps posted to uninstall bundler 1.16 and re-installing bundler 1.15.4 has allowed the tests to run again


#3