Sometimes error occurred when execute rake db:create db:migrate

rails

#1

The circleci runs the tests perfectly until today.I saw this error randomly.Can someone figure out what happened?


#2

Have the same problem today.
But not randomly, it’s happen on all containers for all builds


#3

We are having this problem, as well


#4

Also same problem, including on rebuilds of previously successful commits, using Rails 5. In our case, it’s the nokogiri gem, but the same LoadError from libruby for .so file.

Our is LoadError: libruby.so.2.4: cannot open shared object file: No such file or directory - /home/ubuntu/.../vendor/bundle/ruby/2.4.0/gems/nokogiri-1.6.8.1/lib/nokogiri/nokogiri.so

CircleCI apparently broke the build envs between 6 PM Thursday night and 9 AM Friday (PST), probably in the update to the Ubuntu 14.04 images last night. The new images apparently already include yarn preinstalled, but couldn’t find anything about that in CircleCI’s changelog. Thanks CircleCI :frowning:


#5

Someone having the same problem today?


#6

Same. It was happening all day yesterday (though I was off for a few days and hadn’t built, so it may have been happening for a few days), and it’s happening still today. PG gem for me, as well. Anyone know what’s going on?


#7

Rebuild without cache solved for me.


#8

Worked like a charm. :+1:


#9