Error running orb-tools/increment

I’ve successfully published a dev version of an orb (civicteam/helm@dev:orbs) via circleci using the circleci/orb-tools@2.0.0 orb (publishing an orb for use in circleci via an orb on circleci is cool btw!)

However, I am getting this error when running Increment: “Error: User does not have access to publish SemVer orbs in this namespace.”. I am using the same publish-token-variable for publish and increment and this is a token generated by my github admin account. I also created the namespace itself.

Is the publish-token-variable the place where circle gets the permissions from, or is this based on some other setting in the circle project such as the github ssh key? I presume if I am a github admin I should have permissions to run increment?

Hi @dankelleher

Can you open an issue in the GitHub repo?



1 Like

I ran into this error as well, even after I had updated permissions set in Github. I actually needed to:

  • go into my account in CircleCI and generate a new token
  • run circleci config
  • enter the new token
  • profit

Everything worked great from there.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.