Ember npm test timing out

javascript
ember

#1

Hi! I am suddenly having trouble with npm test for my Ember project. It just hangs after the project is built, before the actual tests are run.

I have re-run previously successful builds and they are now hanging too.

Can anyone think of anything within CircleCI that may be causing this?

Thanks for any help in advance.


#2

Could you please try rebuilding without cache? Does the same thing happen when you run the same command through SSH?


#3

My tests also have been timing out. I’ve tried rebuilding the cache.
When I SSH, I kill the process and run ember test, it also times out.


#4

Hi alexy, thanks for replying. Yes, I’ve tried rebuilding without cache and running the same command through SSH. I got the same result, it just hangs.

Good to hear I’m not the only one Quinn.


#5

My Ember tests also have the same problem with timeout. I’ve tried rebuilding without cache and through SSH, but also hangs in timeout.


#6

We’ve had the same issue. No clue what’s going on.


#7

Follow-up: are you guys using ember-sass in your project? We’ve had some build errors related to node-sass, and I’m wondering if it’s somehow related.


#8

Can somebody run npm test --verbose ? Is it possible run ember test with verbose output?


#9

Try env DEBUG='*' ember test

or

ember test --server


#10

I’m not sure what the best way to share the logs, but here is a screenshot
Let me know what else I can do.

env DEBUG='*' ember test

ember test --server just hangs after the prompt


#11

Hey all, thanks for the tips. Seems like it was a jQuery version issue… try pinning your jQuery version to 1.11.3.

So use "jquery": "1.11.3" in your bower.json.

For some reason I can’t post a link to the github issue so here it is plain text:

https://github.com/ember-cli/ember-cli/issues/5317


#12