Docker Layer Caching on Free plan doesn't seem to work

I’m on a free plan and have enabled DLC for the machine executor (in a private orb). I have a pretty standard nodejs dockerfile, but as i can see, none of the layers are cached. Moreover, i can see the message, that clearly says: Specified using docker layer caching, but it is only available for Performance Plan. Upgrade to Performance Plan to use docker layer caching.

Here is a log of the beginning of the docker build:

These steps should definitely be cached.
So the situation is a bit confusing.
Is the warning about the plan is correct ? Or is it misleading and i am doing something wrong myself? Or did i misunderstood the featue?

I think it is a misunderstanding. The messages you are seeing are coming from the Docker Build command. After every step in the build process, a clean up takes place and so you get these messages regardless of what else is going on. These steps can not be cached as Docker Build has no way of knowing the outcome of a step until it has been processed.

DLC works in the same way that the image cache works on your local development environment, so images that were placed at your repository by Docker Build which are then used during the process of deploying a container are cached locally, rather than them being pulled down from the repository every time you use them.

The detailed docs can be found here

Enabling Docker Layer Caching - CircleCI

Thank you for your reply.
The screenshot is not form the first run of the same dockerfile, of course. It is the second, third. And on my local machine these steps are being cached.
And one the doc page you refer to, there is a video, where exactly there, after a cached step in the dockerfile execution, there is a message, that the cache is being used.

And here is an example of secondary run on my local machine.

Sorry for my mistake - it seems that I’ve been using the feature wrong myself for the last few months :frowning: - Well not wrong just totally disabled with ‘–no-cache --pull’ set on builds to resolve other issues.

Can you post your config.yml file as this is where the control of this feature is handled.

Hi @Emptyfruit,

Sorry to hear that you are running into this issue.

We enabled DLC for free plan users earlier this year, but received reports from other users regarding a similar issue.

I’ve gone ahead and explicitly added the flag for your organization. Could you let me know if builds following this are now using cache? The message about needing the performance plan should go away as well.

If you would like to discuss this in a ticket, please feel free to submit one here:

@rit1010 Thank you for the help as well!

To be honest I missed the most important part of the post, which was rather stupid as I was one of the people reporting the same issue back in January when I first created my account.

Thank you very much, it did help. And the rerun of a previous pipeline took almost no time. And the message is gone.

Have to say, i really enjoy using CircleCI, great work!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.