`docker-compose version` command faild

docker

#1
docker-compose version
Traceback (most recent call last):
  File "/usr/local/bin/docker-compose", line 5, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2749, in <module>
    working_set = WorkingSet._build_master()
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 446, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 459, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 632, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (six 1.5.2 (/usr/lib/python2.7/dist-packages), Requirement.parse('six>=1.10.0'))

docker-compose version returned exit code 1

Action failed: docker-compose version

#2

Fixed this with:

dependencies:
    override:
        ...
        - sudo pip install docker-compose
        - sudo pip install --upgrade six # fix error with docker-compose
        ...

#3

Thanks. That’s saved me a lot of searching/hacking.

I sort of feel that the Docker Compose install is a bit hacky (and the versions are old). Is there any chance this is something that could be looked at improving please @CircleCI-Employees?


#4

+1 for a default install of an up-to-date version of docker-compose.


#5