Docker-compose error maybe due to version issue

docker
circle.yml

#1

I can’t get circleci to run docker-compose up, and I’m just testing out circleci with the demo app from django. It’s the polls app you build in the tutorial.

Answering the questions in “Creating a good question”:

Stack: I’m running python 2.x, a django 1.10.3 web app, and it’s running in a container. The base image for the container is “FROM python:2.7” so it’s some kind of linux distro.

Exact error:

docker-compose up -d
ERROR: In file ‘./docker-compose.yml’ service ‘machine’ doesn’t have any configuration options. All top level keys in your docker-compose.yml must map to a dictionary of configuration options.

Troubleshooting steps taken:
Following advice from here to update circleci’s docker/docker-compose versions to allow for version 2 style docker-compose.yml files (I still get the same error):

machine:
pre:
- curl -sSL amazon/circle-downloads/install-circleci-docker.sh | bash -s – 1.10.0
- pip install docker-compose==1.8.0
services:
- docker

I’m just trying to get it so I can test whether the container will run, and whether I can ping it. I read that this would be a good simple test:

test:
post:
- docker-compose up -d
- curl --retry 10 --retry-delay 5 -v

Links:
CircleCI project: https://circleci.com/gh/bobtista/docker_django_polls/10
Can’t add github link because i’ve hit the limit of links


#2