Docker 1.9.1 is available

docker

#1

We now have Docker 1.9.1 that runs on CircleCI. To use it, you can add the following to your circle.yml. This version has not been tested yet on CircleCI, so please use it with a care. Any bug/issue reports are welcome!

machine:
  pre:
    - sudo curl -L -o /usr/bin/docker 'https://s3-external-1.amazonaws.com/circle-downloads/docker-1.9.1-circleci'
    - sudo chmod 0755 /usr/bin/docker
  services:
    - docker


Docker push much slower as of ~11/17?
Suppress Docker swapiness warnings
Unable to use "docker cp", but it worked 2 days ago
Docker Error removing intermediate container
#2

Is the general plan for Docker service upgrades to be that we do this pre step in the machine block? It’d be really cool if you offered something like you do with java versions where we could spec docker-1.9.1 as the service instead of just docker.


#3

That would be cool. One thing I’m not sure is if the demand for using old docker is high. In my own experiences, I always want to use latest Docker and don’t see the need to switch to old docker.


#4

Makes sense. How frequently are you guys refreshing the containers to contain the latest docker image?

The thing that struck me here is that to get the latest image it’s not just a focus on using the docker service but a curl against an S3 URL.

Latest containers with enterprise seem to be on Docker 1.8, I haven’t looked at the public containers in the last few weeks, are those now default 1.9.1?


#5

There is demand to run different versions of Docker, for example to test resulting images build on different versions. That’s my case :slight_smile:


#6

Using Docker 1.9 is in our plan and definilitely will come soon! (just got busy with other things and couldn’t take for this. sorry!)


#7

Sadly this docker version install breaks the layer caching workaround (docker save|load). Do you know how to fix this?


#8

Another question. docker 1.10.0 arrived with completely new layering concept. (SHA256 fingerprints). I tried using this version but docker refuses to start. Has anyone tried this before?


#9

@bennibu Docker 1.10 is being worked on by CircleCI. I think we’re all super excited for the new layering concept! Docker 1.10 support?


#10

Anyone knows when cache issue will be solved?


#11

@bennibu @alikhan_io

Still beta but you can try Docker 1.10.0 now Docker 1.10.0 is available (Beta)


#12

@kimh In https://github.com/docker/docker/issues/20380 you mention that this works in 1.9.1 but not 1.10.x. Seems to not be the consensus here, though. Does this work with 1.9.1 now or is there a workaround? I thought maybe deleting the docker cache might be a good idea but dunno if its moot.

Your thoughts?


#13