Circleci cli validates my .circle/config.yml as valid, however, circleci ui states I need to upgrade

circleci cli says my .circle/config.yml as valid

$ circleci config validate -c .circle/config.yml

.circle/config.yml is valid

$ circleci --version

Contents of my .circle/config.yml are:

version: 2
    working_directory: ~/myunicornproject
      - image: circleci/2.5.1-node-browsers
          PGHOST: localhost
          PGUSER: santaclause
          RAILS_ENV: test
      - image: postgres:9.5
          POSTGRES_USER: santaclause
          POSTGRES_DB: rudolf
      - checkout

      # Restore Cached Dependencies
      - type: cache-restore
        name: Restore bundle cache
        key: myunicornproject-{{ checksum "Gemfile.lock" }}

      # Bundle install dependencies
      - run: bundle install --path vendor/bundle

      # Cache Dependencies
      - type: cache-save
        name: Store bundle cache
        key: myunicornproject-{{ checksum "Gemfile.lock" }}
          - vendor/bundle

      # Wait for DB
      - run: dockerize -wait tcp://localhost:5432 -timeout 1m

      # Setup the environment
      # - run: cp .sample.env .env
      - run: cp config/application.yml.example config/application.yml

      # Setup the database
      - run: bundle exec rake db:setup

      # Run the tests
      - run: bundle exec rake

However on my circleci app UI, this message is displayed:

This project is currently running on CircleCI 1.0 which will no longer be supported after August 31, 2018. Please start migrating this project to CircleCI 2.0.

Can anyone help? I’m not sure what is wrong here.

Hmm, what’s that triple-dash to start with? I wonder if that might confuse the parser.

Thanks for the suggestion. I tried removing the triple dashes and still get the same message on the UI.

OK. Click on a ran job so you can see the execution details. At the top left, you’ll get the project/run details like so:

Jobs username project branch 123 (build)

To the right of that, you’ll get a CircleCI version, adjacent to a “Rerun job with SSH”. Does it say 2.0? If so, you’re OK.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.