CircleCI can't login into docker during the job execution

docker
circle.yml

#1

The error that I am seeing is:

Login Succeeded
The push refers to a repository [docker.io/myorg/myapp]





denied: requested access to the resource is denied
Exited with code 1

My code is fairly simple:

   # build and push Docker image
      - run: |
          TAG=0.1.$CIRCLE_BUILD_NUM
          docker build -t myorg/myapp:$TAG .    
          docker login -u="$DOCKER_USER" -p="$DOCKER_PASS" hub.docker.com  && docker push docker.io/myorg/myapp:$TAG    

Tried as a separate command and && but no luck.

What’s wrong?

UPDATE

Tried using an ssh build and copy-pasted the above commands. They worked as expected during the ssh session, but not during the actual build.

UPDATE
Trying to encapsulate the docker commands into a separate script file did not resolve the issue either.

UPDATE

OK, figured it out. circle does not support passwords with special symbols well. After changing my hub password to alphanumeric the build started to work.

The only reactions I have to this is: LAME!!! and WTF!? Also pretty useless open source support. My question was hanging out there with multiple updates for 24 hours and not a single response? I guess that’s why jenkins is still a thing. Also, no slack or gitter channel? Really?


#2