Circle2.0 SSH Permissions setup doesn't deploy the key to build machine

ssh

#1

Is “SSH Permissions” still available for Circle2.0. Adding the ssh key on project settings does not seem to deploy the ssh key to build machine. This used to work on Circle 1.0 but for some reason not working on 2.0. i verified that what is pasted on “SSH Permissions” panel matches the ssh fingerprint of what i intended to paste. Also sshing on build machine and looking into the ~/.ssh folder there seems to be a id_rsa file which is completely different than what i pasted on “SSH Permissions” settings page.
It is worth noting that this is a forked build. Not sure if that makes any difference or not.


#2

I am experiencing the same thing. I’ve added two keys already and none show up under /root/.ssh/


#3

Same issue here donatoaz I can’t see anything. I have to add

  • add_ssh_keys:
    fingerprints:
    - “be:06:cs:1e:ce:78:df:fe:42:06:c8:f6:07”

to see any ssh key, but eventhen it doesn’t recognize the hostname despite the fact I see it in .ssh/config


#4