Circle CI 2.0 always build fail even with the commit was built successfully


#1

Hi,

I use docker-compose on CircleCI 2.0 by following the steps on the blog.

My configuration did work before, but it keeps failing today even with the same commit CircleCI built successfully.
Hence it’s possible to be a bug on CircleCI side.

It always fails on building official images from docker hub.

Could you please help on this issue?

Thanks,
Maso

Status: Downloaded newer image for alpine:latest


ERROR: for dynamodb  expected string or buffer

ERROR: for memcached  expected string or buffer

ERROR: for redis  expected string or buffer

ERROR: for elasticsearch  expected string or buffer

ERROR: for postgres  expected string or buffer
Traceback (most recent call last):
  File "/usr/bin/docker-compose", line 11, in <module>
    sys.exit(main())
  File "/usr/lib/python2.7/site-packages/compose/cli/main.py", line 68, in main
    command()
  File "/usr/lib/python2.7/site-packages/compose/cli/main.py", line 118, in perform_command
    handler(command, command_options)
  File "/usr/lib/python2.7/site-packages/compose/cli/main.py", line 926, in up
    scale_override=parse_scale_args(options['--scale']),
  File "/usr/lib/python2.7/site-packages/compose/project.py", line 424, in up
    get_deps
  File "/usr/lib/python2.7/site-packages/compose/parallel.py", line 69, in parallel_execute
    raise error_to_reraise
TypeError: expected string or buffer
Exited with code 1

#2

+1 just trouble shooting the same issue.

– edit

We have a step that updates our docker-compose through pip. It looks like the docker-py version may have changed. Investigation continues.

–edit2

Issue looks to be with docker-py 2.4.0. https://github.com/docker/docker-py/issues/1668

We’re currently fixing by using a requirements:

pip install docker-compose -r requirements.txt

Where requirements.txt contains

docker==2.3.0

Refs



#3

Same problem here…

We also run

dependencies:
pre:
- pip install docker-compose


#4

See my edit above


#5

Thanks @skinofstars !

I ended using just

pip install -I docker==2.3.0

as dependency


Failed to execute docker-compose up
#6

Same here!


#7