[ci skip] not working with VCS Github Checks on

github

#1

When i read that github checks are now supported i wanted to try out.
It worked nice.
But one of my jobs is commiting a version file to github with [ci skip] in comment. So no new build should be triggered.

After switching VCS Github (Github Checks API) on every time the job commited a version file with [ci skip] in comment a new build was triggered.

I did not noticed at once, so about 45 builds with a duration of 10 min. each have been triggered.

After swiching the Github Checks API off, rebaseing the branch (dropped 44 commits) and a commit force the “new” build has been skipped.


#2

I feel like it’s related to my https://discuss.circleci.com/t/github-show-build-as-queued-after-skip-ci-commit


#3

It could be, if you have activated VCS Github checks: https://circleci.com/docs/2.0/enable-checks/

Without the new feature it is working… skipping :slight_smile:


#4

We have fixed ci skip and it should post the correct status on the GitHub Checks tab.


#5

[ci skip] still not working in pull requests.