`[ci skip]` does not work in Pull Requests

github
git

#1

If I commit directly to a branch and add [ci skip] to the message, CircleCI behaves correctly and skips the build. However, if I add [ci skip] to a message of a commit in a Pull Request, CircleCI ignores it and builds anyways. It would be nice if CircleCI respected [ci skip] in the most recent (according to the git graph) commit message. Also would like this to work for [skip ci] too.


#2

I would like to confirm that I’m having the same issue. Is it tracked somewhere else?

It clearly seems like a bug since the docs mention nothing about [ci skip] being unsupported in PRs: https://circleci.com/docs/1.0/skip-a-build/


#3

Here’s an example: https://circleci.com/gh/learningequality/ka-lite/2468


#4

I think this just worked for me today. Is this fixed?

xref: https://circleci.com/gh/conda-forge/staged-recipes/11159


#5

I spoke too soon. It failed to respect [skip ci] on a later build.

xref: https://circleci.com/gh/conda-forge/staged-recipes/11174


#6

So actually after I changed [skip ci] to [ci skip] it worked. In other words, it seems this has been partially addressed as [ci skip] is respected on PRs, but [skip ci] is not.

xref: https://circleci.com/gh/conda-forge/staged-recipes/11175


#7

Looks like this now works! :tada: Thanks so much. Feel free to close this. :smile:


#8

However, it is not working consistently it seems.

xref: https://circleci.com/gh/conda-forge/staged-recipes/11408


#9

Has there been any progress on this?


#10

Today I’d created two GitHub pull requests with “[skip ci]” and “[ci skip]” in their initial commit messages. Both of them triggered Circle-CI tests, something I didn’t expect.

Both PRs have later commits that include the skip text in various places within the commit message … but all subsequent commits did skip Circle-CI’s tests. That’s good, but it would be even better to skip when requested the first time also. :slight_smile:

-Scott


#11