Can't trigger builds with fork and empty Environment Vars in updated config.yml

support

#1

CircleCI: 2.1
Source control: GitHub

Hi everyone, I’m new to CircleCI and everything was going fine until last week.
Here is what happened:
I’ve created a fork (F_GH) from a GitHub repo (A_GH).
This A_GH already has a configured CircleCI webhook and it works as expected.

Issues:
1 - If I set a CircleCI with my personal account for F_GH and then open a PR at A_GH, for some reason the trigger doesn’t works for the PR build.
Workaround: I had to delete my fork with CircleCI and then create another fork without CircleCI to finally open a new PR, this time the trigger worked.

2 - Using the above workaround I opened the PR with modifications in config.yml, and this time something very annoying has happened.
For some reason, the Environment Variables stopped to get visible for my part of config.yml (and not for the old part of config.yml!) at builds. I started to git push some echo for these ENV to debug them while another build was triggered and every time the echo just printed nothing for my part of config.yml and printed the ENV values for the old part. After spend couples hours on this I decided to merge the PR (with red build, to force config.yml updating), this time the echo worked and the merge build was green!
The question here is, this is the natural workflow on updating config.yml?