Can no longer add new BitBucket repo

We’ve got a number of BitBucket repositories that we’ve successfully added over the last year. However, it’s been a month or two since we added one.
Went to do this today with a CircleCI 2.0 config and can’t get past the “Start Building” button. Clicking it eventually turns to “Failed”. If I look in my browser’s dev tools, I can see the following coming back on the “” request:

“Someone has already added that access key to this repository.”

If I look in the BitBucket repo settings, sure enough, there’s an access key there but it was added when I clicked the “Start Building” button (i.e. no one else previously added it), so I know CircleCI’s talking to BB correctly. If I manually delete the access key and try again, the key is added to BB again but we still get the error message.
We tried on a brand new BB repo and still have the same issue.

Unfortunately, this is completely blocking us :(. Any ideas?


Can you open a ticket and ping me the ticket number? Had to say without the project info, and offhand I’m not sure what could be causing this so I’d like to take a look at the state on our side.

Done. Thank you Joseph!

1 Like

Just an FYI for others who might be experiencing this. Turns out that there’s some sort of issue with CircleCI provisioning the access key over in BitBucket. The key gets created but somewhere along the lines, something is attempting to create it a second time and the project doesn’t get created properly in CircleCI.
So, to get around this, we needed to edit the project (under “Settings”->“Projects”->click the gear next to the repo) and created a read/write SSH key that we then added into BitBucket (details here: Once we did this and then “followed” the project, we were able to move forward. Not ideal, for sure, but this at least gets us going again.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.