Troubleshooting failed to clone;


#1

I have a couple of (private) projects I use circleci for. One is a backend and one a frontend. As far as I remember I have set them up the same. Everything worked fine, I recently created a (private) package to share some common things across them. But one of my projects always fails and says it can’t clone the private repo, where one succeeds. They both have the same key for their repo access

I’ve tried looking at the checkout ssh on the project page, but the link to Bitbucket dies. In fact so does the link for working project too. What’s the best way to proceed here?


#2

Would you clarify what you mean here?


#3

Hi @halfer

On the SSH page configuration in circleci for a particular project, there is a link to deploy keys you have currently. I am assuming it will take me back to bitbucket and show me the assigned key. But when I click the link bitbucket tells me that this is a 404.


#4

Hmm, I seem to recall someone mentioning 404 links here on the forum. I would suggest unfollowing the project in CircleCI and then re-following it, and then re-add the key. I think that has a resetting effect.


#5

Ok, i figured this out. I needed to add both circle ci keys to to the packages keys.
Thanks for your help :slight_smile: