Builds are "Not run" after merging to develop ("Only build PRs" is on, but develop is a default branch)

Hi!

We’ve met some problems with building our apps a couple of days ago.

Builds are not run for merges to develop with the following reason:

This project is configured to only run builds that have open pull requests associated with them. Update the ‘Only build pull requests’ setting to run this build.

“Only build pull requests” is on, but according to the description and our GitHub default branch, it should work and here’s why.
I’ve double-checked the description of the setting and it says: «For your default branch, we will always build all commits». I’ve double-checked the default branch on the GitHub and it’s definitely «develop».
Moreover, this issue appears without any changes from our side about three days ago. It just worked before.

So I’ve got no idea why it doesn’t work now and what I have to do to make it works again =)

2 Likes

Run into the same problem today!

If you want it to always build on only the develop branch I’d consider using the filters feature

workflows:
  parallel_builds:
    jobs:
      - code_switch:
          filters:
             branches:
               only:  # only branches matching the below regex filters will run
                 - develop
                 - qa
                 - demo

https://circleci.com/docs/2.0/configuration-reference/#filters-1

I think that defeats the point of the intended feature.

What I want (and assume @Vladlex has the same intention) is:

  • Run CircleCI workflow for feature branches only when a PR is open.
  • After merging, run CircleCI workflow in the default branch

I already use filters to run certain jobs only on a feature branch or in the default branch.

2 Likes

@Vladlex any news or work arounds?

We had to move to another service because of this, sorry.

Ok, thanks!
How can I get someone from the CircleCI team to address/say something about this issue?

This is insane to me. This is a total blocker for me moving into CircleCI (I just ran into this in our POC). I guess I’ll look for alternative services, very disappointing.

You could open a ticket at support@circleci.com.

That’s fair enough - CI services surely can’t be all things to all people. However, there aren’t many good CI hosted systems avaiable, so it is worth taking as positive frame of mind as you can muster. For example, if you decide to try a PoC on Travis, then you might fix this thing, and have some other thing not work, which CircleCI does very well. Sometimes you have to make compromises (and of course there is no “perfect” CI system - everything is a trade-off).