Build .Net4.8 application

Is it possible to build a dotnet 4.8 image in CircleCI since the current default version of dontnet is 5 on the executor: win/default

Hello

You can install any version you’d like on top of the Windows executor in addition to the version installed currently as an additional step.

You may need to specify that version in a global.json file.

This is due to the “use latest” policy which means you need to use a global.json file to specify a .NET SDK version earlier than the latest installed version.

More information on the file can be found here: Select which .NET version to use - .NET | Microsoft Docs

If you have any questions please feel free to ask.

Kind Regards

Hi @owenjoliver

I have tried to install 4.8 using Chocolatey
choco install netfx-4.8-devpack
However when I check all the versions of .Net Installed I dont see 4.8

dotnet --list-sdks
2.2.401 [C:\Program Files\dotnet\sdk]
3.0.100 [C:\Program Files\dotnet\sdk]
3.1.406 [C:\Program Files\dotnet\sdk]
5.0.401 [C:\Program Files\dotnet\sdk]
5.0.404 [C:\Program Files\dotnet\sdk]