Artifacts are collected successfully but are not listed for download

Hello,

I just finished setting up a new CI integration for a new project, and everything seems to be working fine, except that artifacts are not showing up in the “Artifacts” tab at the end of the build.

If you take a look at build #18, for example, you can see that it successfully located and (apparently) uploaded the artifacts:

Uploading /tmp/vak-app.zip to /
Uploading /tmp/vak-app.zip (4.0 MB): DONE

But when I go to the Artifacts page, I see only a blank screen. I also tried accessing it through the CircleCI API, to no avail.

The other job I set up as part of this workflow similarly fails to display the artifacts. If you look at build #19, you’ll see the following log:

Uploading /root/project/VakExtension/vak-extension.vsix to /
Uploading /root/project/VakExtension/vak-extension.vsix (3.2 MB): DONE

While I was still trying to set up the CI pipeline, I did manage to upload and display artifacts at one point, when one of the jobs failed and the artifacts were not ZIPed, just loose files in a folder.

I’ve tried re-running the builds, and I got the same result. I believe this is therefore a bug, and I apologize if I’ve actually simply forgotten a step or misunderstood how artifact storage works in pipelines. Any help would be appreciated. :slight_smile:

The artifacts have still not showed up on these builds. Any suggestions?