Some artifacts not available


#1

We collect a lot of build artifacts by specifying custom artifact files as described here:
Specifying custom artifacts directories and files

A few days ago this was all working normally. But recently this has stopped working properly - some of the files are available via the “Artifacts” tab on a build, but not all of them.

Our circle.yml file contains something like this (shortened and sanitised):

general:
  artifacts:
    - hashdb_linux.csv

    - build/linux/test/test_core
    - build/linux/test/test_core_lint_summary.txt
    - build/linux/test/test_core_lint_warnings.txt
    - build/linux/test/test_core_tests.csv
    - build/linux/test/test_core_cov.cov
    - build/linux/test/test_core_cov.html

    [lots more of the above]

    - hashdb_target.csv

    - build/target/test/test_core
    - build/target/test/test_core_lint_summary.txt
    - build/target/test/test_core_lint_warnings.txt
    - build/target/test/test_core_tests.csv
    - build/target/test/test_core_cov
    - build/target/test/test_core_cov.cov

    [lots more of the above]

All of the build/linux files are available via the via the “Artifacts” tab on a build.
None of the build/target files are available via the “Artifacts” tab on a build (they were available in older builds from a few days ago).
I’ve confirmed via an SSH build that the build/target files are being built.
The build report shows success (green) for the “Collect artifacts” step.

I have also tried doing an explicit copy to $CIRCLE_ARTIFACTS e.g.:

test:
  post:
    - mkdir $CIRCLE_ARTIFACTS/msgshow
    - cp hashdb_linux.csv  $CIRCLE_ARTIFACTS/msgshow
    - cp hashdb_target.csv $CIRCLE_ARTIFACTS/msgshow

    - mkdir $CIRCLE_ARTIFACTS/target
    - cp --recursive build/target $CIRCLE_ARTIFACTS/target

None of these are available via the via the “Artifacts” tab on a build, even though the build report show success (green) for the “Collect artifacts” step.

Does anyone have any suggestions as to what might be causing this?

Thanks for your assistance,
Simon


#2

Hello,

Are you still seeing this issue?


#3

I’ve ran some tests last night on some old builds (with large numbers of
artifacts) and I am no longer seeing this issue - it seems to be working
correctly at the moment.

Note that 2 days ago we modified our circle.yml file to minimise the number of
artifacts that we collected - it consistently worked OK for a small number of
artifacts (less than 100 or so), whilst consistently failing for large numbers
of artifacts (our old circle.yml file was collecting 2000+ small files).


#4